Blur Busters Forums

Who you gonna call? The Blur Busters! For Everything Better Than 60Hz™ Skip to content

CSGO feels like 60hz

Everything about input lag. Tips, testing methods, mouse lag, display lag, game engine lag, whole input lag chain, VSYNC OFF vs VSYNC ON, and more!

CSGO feels like 60hz

Postby crankz » 22 Aug 2017, 11:03

Hey guys, ive had this issue for so long and still havent found a fix...
Basically i have 200-300fps, 144 hz and good ping and my game still feels like crap.
When ever i re-install windows or game (sometimes) it feels good for a few days then it goes back to the same...

My Setup:

i5 4460
b85-g43 gaming
gtx 960
1x8GB Kingston HyperX Savage DDR3-1600
hyperx ssd fury 120gb
xfx 550w
Benq XL2411Z
SS Rival

DX Diag :

https://pastebin.com/MLa547GW

Ram Timmings :

Image


SSD Benchmark : (Bad as fuck, this ssd is a cancer)

Image
Image


Please guys could u help me? this is skillcaping my game so much
crankz
 
Posts: 10
Joined: 22 Aug 2017, 10:55

Re: CSGO feels like 60hz

Postby lexlazootin » 22 Aug 2017, 11:07

Type mat_info into console and paste the text, it should display in game hz which might be set to 60hz and not 144hz.

In your NVCP "Manage 3D settings" make sure the "Preferred refresh rate" is set to highest available and your current refreshrate is 144hz.

Also make sure your mouse is set to 1000hz
lexlazootin
 
Posts: 909
Joined: 16 Dec 2014, 02:57

Re: CSGO feels like 60hz

Postby crankz » 22 Aug 2017, 11:15

lexlazootin wrote:Type mat_info into console and paste the text, it should display in game hz which might be set to 60hz and not 144hz.

In your NVCP "Manage 3D settings" make sure the "Preferred refresh rate" is set to highest available and your current refreshrate is 144hz.

Also make sure your mouse is set to 1000hz


It says 144hz, mouse is set to 1000hz aswell. And i have that on nvidia aswell :oops:
crankz
 
Posts: 10
Joined: 22 Aug 2017, 10:55

Re: CSGO feels like 60hz

Postby lexlazootin » 22 Aug 2017, 11:38

Make sure you are also running exclusive fullscreen and not just border-less fullscreen.

Try setting your fps to 'fps_max 144' it will draw a tearline in the middle of your screen but it might make it feel better. when you show fps with cl_showfps 1 does it jump around a lot or stay at 144fps stable?

A guess would be some background application taking priority. make sure you have power setting in windows set to "High Performance" and open task manager and disable all the startup application in 'Startup' this will require you to restart.

Also you can try opening msconfig from run and disabling any non-Microsoft service that doesn't need to be.

Is your CPU/GPU throttling by any chance?

Edit: You're using a NV driver from 2016, although i don't think it would be it but it doesn't hurt to update it.
lexlazootin
 
Posts: 909
Joined: 16 Dec 2014, 02:57

Re: CSGO feels like 60hz

Postby RealNC » 22 Aug 2017, 13:59

Update your driver:

http://www.nvidia.com/Download/Find.aspx?lang=en-us

Then go to Windows Settings and disable Game DVR and Game Bar.
The views and opinions expressed in my posts are my own and do not necessarily reflect the official policy or position of Blur Busters.
User avatar
RealNC
 
Posts: 1226
Joined: 24 Dec 2013, 18:32

Re: CSGO feels like 60hz

Postby crankz » 22 Aug 2017, 22:40

RealNC wrote:Update your driver:

http://www.nvidia.com/Download/Find.aspx?lang=en-us

Then go to Windows Settings and disable Game DVR and Game Bar.



I had the same issue with the latest driver, i just installed that one cuz people recommended me that
crankz
 
Posts: 10
Joined: 22 Aug 2017, 10:55

Re: CSGO feels like 60hz

Postby RealNC » 23 Aug 2017, 01:57

What does "mat_info" say?
The views and opinions expressed in my posts are my own and do not necessarily reflect the official policy or position of Blur Busters.
User avatar
RealNC
 
Posts: 1226
Joined: 24 Dec 2013, 18:32

Re: CSGO feels like 60hz

Postby crankz » 24 Aug 2017, 16:55

ShaderAPI: shaderapidx9.dll
Shader API Driver Info:

Driver : nvd3dum.dll Version : 5911064706096250
Driver Description : NVIDIA GeForce GTX 960
Chipset version 4318 5121 915346520 161

Display mode : 1024 x 768 @144Hz (BGRX8888)
Vertex Shader Version : 3.0 Pixel Shader Version : 3.0

Device Caps :
CANBLTSYSTONONLOCAL Y CANRENDERAFTERFLIP Y HWRASTERIZATION Y
HWTRANSFORMANDLIGHT Y NPATCHES N PUREDEVICE Y
SEPARATETEXTUREMEMORIES N TEXTURENONLOCALVIDMEM Y TEXTURESYSTEMMEMORY N
TEXTUREVIDEOMEMORY Y TLVERTEXSYSTEMMEMORY Y TLVERTEXVIDEOMEMORY Y

Primitive Caps :
BLENDOP Y CLIPPLANESCALEDPOINTS N CLIPTLVERTS Y
COLORWRITEENABLE Y MASKZ Y TSSARGTEMP Y

Raster Caps :
FOGRANGE Y FOGTABLE Y FOGVERTEX Y ZFOG Y WFOG Y
MIPMAPLODBIAS Y WBUFFER N ZBIAS Y ZTEST Y
Size of Texture Memory : 0 kb
Max Texture Dimensions : 16384 x 16384
Max Texture Aspect Ratio : *16384*
Max Textures : 8

Texture Caps :
ALPHA Y CUBEMAP Y MIPCUBEMAP Y SQUAREONLY N
vendor id: 0x10de
device id: 0x1401
SHADERAPI CAPS:
m_NumSamplers: 16
m_NumVertexSamplers: 4
m_HasSetDeviceGammaRamp: no
m_SupportsPixelShaders_2_b: yes
m_SupportsShaderModel_3_0: yes
m_SupportsCompressedVertices: 1
m_bSupportsAnisotropicFiltering: yes
m_nMaxAnisotropy: 16
m_MaxTextureWidth: 16384
m_MaxTextureHeight: 16384
m_MaxTextureAspectRatio: 16384
m_MaxPrimitiveCount: 16777215
m_ZBiasAndSlopeScaledDepthBiasSupported: yes
m_NumPixelShaderConstants: 224
m_NumVertexShaderConstants: 256
m_NumBooleanVertexShaderConstants: 16
m_NumIntegerVertexShaderConstants: 16
m_TextureMemorySize: 0
m_MaxNumLights: 4
m_MaxVertexShaderBlendMatrices: 53
m_SupportsMipmappedCubemaps: yes
m_nDXSupportLevel: 95
m_PreferDynamicTextures: yes
m_MaxUserClipPlanes: 6
m_SupportsSRGB: yes
m_HDRType: HDR_TYPE_INTEGER
m_UseFastClipping: no
m_pShaderDLL:
m_bNeedsATICentroidHack: no
m_bDisableShaderOptimizations: no
m_MaxSimultaneousRenderTargets: 4
m_bPreferZPrepass: no
m_bSuppressPixelShaderCentroidHackFixup: no
m_bPreferTexturesInHWMemory: no
m_bPreferHardwareSync: yes
m_bUnsupported: no
crankz
 
Posts: 10
Joined: 22 Aug 2017, 10:55

Re: CSGO feels like 60hz

Postby Kulagin » 24 Aug 2017, 22:49

crankz wrote:Hey guys, ive had this issue for so long and still havent found a fix...
Basically i have 200-300fps, 144 hz and good ping and my game still feels like crap.
When ever i re-install windows or game (sometimes) it feels good for a few days then it goes back to the same...

Delete all Windows 10 apps(especially XBOX DVR). Don't just disable them. Delete them.
What Nvidia drivers you use? I've read enough about 'latest' nvidia drivers, very often they're bad compared to some 'good ones'. I recommend 372.90. 368.81 is also good but 372.90 is better(and the best I found so far). Install drivers as described here. I recommend also deleting physX folder. Do you change any Nvidia settings after you install your Nvidia drivers?

What about in-game launch options, do you use any? Don't use any controversial, like -processheap, -high, -threads, -nod3d9ex, etc.

Then there's also this bug:
http://www.overclock.net/t/1433882/gami ... t_23196800
http://www.overclock.net/t/1372936/guid ... -input-lag

And then there's a bug that drops frequencies on your video card, like this:
Image

From what I've read it happens more to people with overclocked monitors(like your 144 Hz) with reduced blanking.

Sometimes it drops shader clock to 51, sometimes to 400 or something. You'll still get your 200-300 FPS in CS with your GTX 960 but lag will me much more bigger. Install Afterburner and monitor your video card frequencies.

What's up with your PCI devices? Any IRQ conflicts?
https://forums.guru3d.com/threads/windo ... ts.378044/

Well, if I was on your place(and I was), I would start fixing it from the foundation - hardware. Make sure you don't have any problems on hardware level, like overheating or multiple heavy devices on the same physical IRQ line working in line-based mode. After fixing problems on hardware level switch to BIOS. Here's a nice thread about it.

And after you fix your BIOS, you can switch to Windows.
Kulagin
 
Posts: 6
Joined: 27 Feb 2016, 08:17

Re: CSGO feels like 60hz

Postby crankz » 24 Aug 2017, 23:19

Ive deleted all windows apps.
Im using the 372.90 driver and using the nvidia settings for performance. Ive also always installed drivers that way.
Im using -freq 144 -tickrate 128 -novid and -high as it gives me like a 15% fps boost.


I cant change from gpu to display scalling even after creating a custom reso at 143hz...

I will have to check that bug... but i dont think it happens.


Ive used that tool and changed everything to msi mode besides the realtek driver has recommended by people on r0ach guide.


Thanks for the help...
crankz
 
Posts: 10
Joined: 22 Aug 2017, 10:55

Next

Return to Input Lag

Who is online

Users browsing this forum: No registered users and 3 guests