Page 1 of 1

BlurBuster Strobe Utility "No Compatible Monitors" issue

PostPosted: 07 Jan 2017, 13:44
by blueramza
So I just got the BenQ Zowie xl2720 and have confirmed it is on firmware v2. I tried to use this link to calibrate the monitor

https://www.reddit.com/r/pcmasterrace/c ... /?sort=new

All was going good until I got to the blurbuster strobe utility part. I have the correct driver installed and it shows "Zowie XL LCD (digital)" instead of the "generic pnp thing.

Yet the utility still says No Compatible Monitors Detected.

Am I doing something wrong or is this version of the monitor not supported.

Thank you for your time.

Re: BlurBuster Strobe Utility "No Compatible Monitors" issue

PostPosted: 07 Jan 2017, 14:23
by Q83Ia7ta
this version of the monitor not supported afaik.

Re: BlurBuster Strobe Utility "No Compatible Monitors" issue

PostPosted: 07 Jan 2017, 14:52
by blueramza
Q83Ia7ta wrote:this version of the monitor not supported afaik.


Which is odd since its just a rebranded 2720z 0_0. Maybe they just need to add the certificate or name variation?

Re: BlurBuster Strobe Utility "No Compatible Monitors" issue

PostPosted: 07 Jan 2017, 19:04
by Falkentyne
blueramza:
I know I'm asking a lot, but is it possible if you can "dump" the firmware into a BIN file, using Linux (Ubuntu?). I'm looking for a dump of the Zowie branded XL2720Z's.

Re: BlurBuster Strobe Utility "No Compatible Monitors" issue

PostPosted: 08 Jan 2017, 00:16
by blueramza
Falkentyne wrote:blueramza:
I know I'm asking a lot, but is it possible if you can "dump" the firmware into a BIN file, using Linux (Ubuntu?). I'm looking for a dump of the Zowie branded XL2720Z's.

Im not sure how... but if its a simple process I can try to do it. Is this possible on windows 7?

Re: BlurBuster Strobe Utility "No Compatible Monitors" issue

PostPosted: 08 Jan 2017, 02:04
by Falkentyne
Yes its very easy. but you need a USB boot flash drive, (at least 2 gb).

The instructions are here:

------------

First grab a USB flash drive. 8 GB+ works best, though I did use an empty 2 GB one.
Get the ISO for Linux (Ubuntu)
http://releases.ubuntu.com/14.04/
I used the i386 one for my core i7.

Download the easy to use USB installer here:
"http://www.pendrivelinux.com/universal-usb-installer-easy-as-1-2-3/"

Install it then boot to the flash drive and run the try Ubuntu mode.
When it finishes loading, open a terminal (Ctrl + Alt + T);
type "sudo gedit /etc/apt/sources.list" without the quotes to bring up the editor.
At the end of the second line, add "universe multiverse" so the line looks exactly iike this:

"deb http://archive.ubuntu.com/ubuntu/ trusty main restricted universe multiverse"
Save and exit the sources.list file.

Then type "sudo apt-get update"
That should download some updates.
Then type:
"sudo apt-get install i2c-tools subversion libpci-dev"
That should update and install some package lists.

You MIGHT also need this command too. This is in case some usb libraries are missing.
"sudo apt-get install libusb-dev"

If everything installs correctly, great.
But now things get tricky.

Using the instructions on this website, you need to find and backup the V4 firmware. The hard part is actually finding the i2c bus where it's located.

"http://boeglin.org/blog/index.php?entry=Flashing-a-BenQ-Z-series-for-free(dom)"

Type these commands: Remove any quotes I put, though, including the quotes in the wget command (trying to bypass link creation).

"svn co svn://flashrom.org/flashrom/trunk@1846 flashrom"
"cd flashrom"

wget -O- "http://boeglin.org/static/benq/0001-Add-programmer-for-the-MSTAR-I2C-ISP-protocol.patch | patch -p1" (<---the | is the shifted \ key, aka the "Pipe" symbol). On this website, that link shows up truncated with "...." unless you mouse over it. The full link without truncation is on the main site: "http://boeglin.org/blog/index.php?entry=Flashing-a-BenQ-Z-series-for-free(dom)"

*Remove the quote before http and after -p1 !! *

The actual command is:
wget -O- http://boeglin.org/static/benq/0001-Add ... ocol.patch | patch -p1
(you can see what the link creation does to make it hard to see what to type. In future steps, you will require quotes (for the flash type chip later))

next is building the flashrom patcher with the stuff you downloaded last few steps :)

"make -j" (<-this should make the flashrom patcher with the data for the mstar scaler)

"sudo modprobe i2c-dev"

"sudo i2cdetect -l" <--this lists all i2c buses

"sudo i2cdetect 1" <---this lists al i2c buses on bus 1.

"sudo i2cdump -r 0-127 1 0x50" <--- get EDID (0x50) from bus 1. You are looking for an EDID dump that shows the monitor name in it. You may have to change the 1 to a 0 ( 0 0x50 instead of 1 0x50), or you may have to change 0x50 to 0x49 (usually you don't ever have to do that). Once you find the dump that says "XL2411Z, XL2420, XL2720, XL2430T" or what your monitor type is then you're good to go. In some cases your monitor may be on bus 0, thus the change from a 1 to a 0.

It's possible that the monitor could be on a bus as high as 5 or 6. Keep that in mind.

(edit):
If you are using a laptop through VGA, you SHOULD be able to find the monitor i2c identifier name easily. If you are using a desktop through DVI and flashing through the desktop and you can not find the monitor bus or get random data where the monitor 'should' be located (or in the rare case that the laptop can't see it through VGA, reboot the host computer back to windows and install the monitor driver from the DVD (device manager or displays in control panel); this has been confirmed to have helped people who kept getting "Unknown" data on the i2c bus. (0x50 buses 0-4 usually). Not sure why this works; maybe Linux has access to installed inf data.

"sudo ./flashrom -p mstarddc_spi:dev=/dev/i2c-1:49" <----# identify flash chip, on bus 1 (/dev/i2c-1) at address 0x49. Change the 1 to a 0 if you are on bus 0. If your monitor is on bus 5 or 6 or something then change the number to that.

(dump current firmware)
sudo ./flashrom -p mstarddc_spi:dev=/dev/i2c-1:49 -c "MX25L1605A/MX25L1606E" -r backup.bin <--again change the 1 to a 0 if you are on bus 0 or a higher# for a higher bus.. You need the quotes around the flash chip type.

------------------------

Once you make the dump of backup.bin, copy it into one of your folders where you can access it in windows, boot back to windows and upload it somewhere.

Re: BlurBuster Strobe Utility "No Compatible Monitors" issue

PostPosted: 08 Jan 2017, 17:53
by blueramza
Falkentyne wrote:Yes its very easy. but you need a USB boot flash drive, (at least 2 gb).

The instructions are here:



Ok thank you. I will give this a go and update you when I get the time asap.

Re: BlurBuster Strobe Utility "No Compatible Monitors" issue

PostPosted: 09 Jan 2017, 12:39
by Falkentyne
Thank you. Let me know if you have any problems. I can check the accuracy of the dump when you're done as the "raw" size of data should be around 850k but the bin file will be 2 mb in size (so 1.1mb of empty space).

Re: BlurBuster Strobe Utility "No Compatible Monitors" issue

PostPosted: 09 Jan 2017, 15:49
by SchnakeEyes
Im assuming with this, you'll be able to hand us back the blur busters program for these new units? :)

Re: BlurBuster Strobe Utility "No Compatible Monitors" issue

PostPosted: 09 Jan 2017, 16:06
by Falkentyne
I'm not chief blur buster.

I want to flash my XL2720Z with the Zowie firmware. I own the Mstar ISP unit.