Electricity input lag fix !

Everything about latency. Tips, testing methods, mouse lag, display lag, game engine lag, network lag, whole input lag chain, VSYNC OFF vs VSYNC ON, and more! Input Lag Articles on Blur Busters.
Post Reply
yonaxsangi
Posts: 36
Joined: 11 Mar 2021, 06:06

Electricity input lag fix !

Post by yonaxsangi » 18 Apr 2021, 10:56

Ok hello guys first of all sorry for my english its not good but ill try my best to help for people who have this annoying electricity problem.

i lived with this inout lag for 5 years without potential fix i tried every windows tweaks nvidia drivers, motherboard drivers, changing most parts of the computer, monitor changing the electricity wires, outlets, own grounding, earthing, surge protectors, emi filters. those things will improve things for 1 hour but u will still get the problem after some amount of time.
I mainly play csgo, 2400 elo faceit , global elite
but i achieved this ranks and level just because of experience and even low lvl or ranked players always prefired me holding position is almost impossible, i have benq 2540 240hz monitor but it feels like its has alot of input lag like make the monitor feels like 10ms!! it should be 1ms. the player movement its too fast tracking is like almost impossible the hitreg is bad u spray and pray to kill an enemy.

-But i have some fix but its not 100%
i can say its very consistent i played like 3 days in the morning and night its always the same(consistent).

I dont know if it will work for some people but for me its worked perfectly its not like 100% fix but i can say its 70% and its playable now.
- so guys i have gigabyte z390 aorus pro motherboard and i saw one guy said theres hidden feature called RFI spread spectrum , PCIE spread spectrum so i enabled all of them from software called AMIBCP and updated my bios. what it does its reduced my RFI/EMi to almost 50mv its like nothing , before it was 850mv is too high and risky for health also. so try to edit your bios and enable all this features.

deama
Posts: 267
Joined: 07 Aug 2019, 12:00

Re: Electricity input lag fix !

Post by deama » 18 Apr 2021, 13:35

For those wondering what spread spectrum does, it effectively varies the various clocks (CPU, PCIe, etc...) on the mobo, and is not a good idea to do if you're overclocking as it will destabilize it, even in general.
https://www.anandtech.com/show/2500/20

I think the reason it worked for the user here is because it reduced the EMI emission in an area where he had high EMI already, not exactly sure how, the above post mentions something about it reducing EMI by fluctuating the frequencies (clocks).
But from reading more about it, it seems like it's a bad idea to enable if you're system is stable.
Could be worth it to try out if you're having big problems and this can give you a quick fix. Obviously though it would be better to fix the root cause of this and keep it disabled as that should give you better results, though not everyone has the capital to fix this.

Then again though, I found another article stating that it shouldn't interfere with speed/stability, so who knows, more tests are needed.
I'll enable this myself and see how it goes.

blackmagic
Posts: 124
Joined: 12 Jan 2021, 08:57

Re: Electricity input lag fix !

Post by blackmagic » 18 Apr 2021, 15:36

i would rly like to see more on this and maybe people that can do tests and show better how it affects the games...

the only thing i find and read on internet was people who tell that there games are speed up like speedhack and that in new games after overclocking but maybe there is a chance that emi is causing this bug when overclocking...

i know that old games have this speedhack effect when the cpu is newer generation with more cores and i even experienced something like this but i forget what game it was...not sure but i think it was scarface where you need disable other cores and leave only 2 so the game works in normal speed.

i have here z390a pro msi but there 0 options on spread spectrum and noticed that i dont have hpet enable/disable option...

my old more low budged motherboard had 1 x spread spectrum option and hpet...

is it possible that this spread spectrum can fail after some time on motherboards and become like useless without effect ?


i downloaded your software for edit bios but it seems like it dont works for uefi bioses...
so i get another bios editor for uefi and try right now to figure out if there is too somewhere a hidden spread spectrum options...but i cant find that stuff... :|

looks like im going now to buy another motherboard because this rly interesting and i find more users who say same and that this option fixes or makes things better in online...


edit:

this all makes somehow sense to me...

before the issues here i had a mobo with spread spectrum and maybe it was enabled by default idk or i enabled it but i know that i feel very comfortable for like more 1 year and dont know any issues here until the day when everything become absurd and rly bad...

but when this issue appeared here and i start notice it more and more...
i always had this feel that my games run like on speed...this sounds crazy and many would not believe but it is what it is...
its hard to proof and see this just by recording but when looking on my display i can just feel and see that things are somehow speeded up and just running not at the correct timings,speed or are messed up...

the first time it was very strange feeling and this speed up is still noticeable here...

my english is way to bad to describe this all better...

but that just some edit to my story and maybe someone here had same experience or noticed this change too at his place ?
Last edited by blackmagic on 18 Apr 2021, 21:35, edited 7 times in total.

deama
Posts: 267
Joined: 07 Aug 2019, 12:00

Re: Electricity input lag fix !

Post by deama » 18 Apr 2021, 16:17

Ok so I tested with the spread spectrum on and off for a few hours and it definitely feels better with it off. I don't have any electricity issues, so I would assume that with it off yields best results, and that is true, but maybe other people might wanna try enabling it if they know they have electricity issues or some sort of issue and have tried a bunch of different things.

pox02
Posts: 201
Joined: 28 Sep 2018, 06:04

Re: Electricity input lag fix !

Post by pox02 » 18 Apr 2021, 16:28

i have one fix for u yonaxsangi switch ur power supply with good unit with a really good emi filter like hx1200i or ssr-1000tr from seasonic looks the difference


good word about spread spectrum

spread spectrum is a hot topic of debate if it actually "works" it's just spreading out the energy some more. it doesn't reduce the overall power leakage
it helps meet the legal requirements, but the effect on actual interference is debated

sorry yonaxsangi the whole problem come from PSU

ax1600i Huge emi

https://streamable.com/hijvkt

hx1200i Extreme low emi

https://streamable.com/skoc1u
monitors xg258q aw2518hf 27GK750F-B pg248q xg240r lg w2363d-pf xb270hu XL2546 XL2546K NXG252R AW2521H(main) :D

blackmagic
Posts: 124
Joined: 12 Jan 2021, 08:57

Re: Electricity input lag fix !

Post by blackmagic » 18 Apr 2021, 18:56

i need some help here...

so i downloaded another AMIBCP patched one that i find in youtube under a video...
and with this one i managed to open my bioses:
https://www.msi.com/Motherboard/support/Z390-A-PRO


i find there many of stuff and RFI spread spectrum:
https://i.imgur.com/JTDSF8S.png
Image

this maybe interesting too:
https://i.imgur.com/F7JnKFI.png
Image


same i can see in this tool uefibioseditor:
https://i.imgur.com/mHtThpW.png
Image

can u make step by step how you enable this options for your bios ?
im way to stupid and never done before some edits on mb bioses...

is this even possible to do for my mb ?


edit: another thing that i find in all that was the hpet option which i cant see and find too in my bios menu but in the bios editor reads it says that hpet enabled = yes...

maybe that could be an issue too because in windows 10 hpet is disabled by default and i read that it either should be on/on or off/off bios and windows...
but if i enable hpet in windows then my fps drops from 200fps to 40-50fps and its hard stuttering in games...unplayable.

yonaxsangi
Posts: 36
Joined: 11 Mar 2021, 06:06

Re: Electricity input lag fix !

Post by yonaxsangi » 19 Apr 2021, 01:08

hello brother in the first picture put RFI spread spectrum to 6% from 1.5%.
in the second picture put the spread to 255. if u want i can enable for u all the spread spectrum for the maximum just send me your bios ill edit for you. i have z390 pro mobo and disabling hpet drops the fps about 40-50 fps so i think in z390 motherboards its not working well.

yonaxsangi
Posts: 36
Joined: 11 Mar 2021, 06:06

Re: Electricity input lag fix !

Post by yonaxsangi » 19 Apr 2021, 01:10

blackmagic wrote:
18 Apr 2021, 15:36
i would rly like to see more on this and maybe people that can do tests and show better how it affects the games...

the only thing i find and read on internet was people who tell that there games are speed up like speedhack and that in new games after overclocking but maybe there is a chance that emi is causing this bug when overclocking...

i know that old games have this speedhack effect when the cpu is newer generation with more cores and i even experienced something like this but i forget what game it was...not sure but i think it was scarface where you need disable other cores and leave only 2 so the game works in normal speed.

i have here z390a pro msi but there 0 options on spread spectrum and noticed that i dont have hpet enable/disable option...

my old more low budged motherboard had 1 x spread spectrum option and hpet...

is it possible that this spread spectrum can fail after some time on motherboards and become like useless without effect ?


i downloaded your software for edit bios but it seems like it dont works for uefi bioses...
so i get another bios editor for uefi and try right now to figure out if there is too somewhere a hidden spread spectrum options...but i cant find that stuff... :|

looks like im going now to buy another motherboard because this rly interesting and i find more users who say same and that this option fixes or makes things better in online...


edit:

this all makes somehow sense to me...

before the issues here i had a mobo with spread spectrum and maybe it was enabled by default idk or i enabled it but i know that i feel very comfortable for like more 1 year and dont know any issues here until the day when everything become absurd and rly bad...

but when this issue appeared here and i start notice it more and more...
i always had this feel that my games run like on speed...this sounds crazy and many would not believe but it is what it is...
its hard to proof and see this just by recording but when looking on my display i can just feel and see that things are somehow speeded up and just running not at the correct timings,speed or are messed up...

the first time it was very strange feeling and this speed up is still noticeable here...

my english is way to bad to describe this all better...

but that just some edit to my story and maybe someone here had same experience or noticed this change too at his place ?

if u can send me your bios i can enable for you all the spread spectrum, hpet whatever u want brother. i had the speedhack effect in the game too especially in csgo it was basically happens in the nights. something crazy the player movement is like i increased it by 5x like in the youtube lol

yonaxsangi
Posts: 36
Joined: 11 Mar 2021, 06:06

Re: Electricity input lag fix !

Post by yonaxsangi » 19 Apr 2021, 01:19

pox02 wrote:
18 Apr 2021, 16:28
i have one fix for u yonaxsangi switch ur power supply with good unit with a really good emi filter like hx1200i or ssr-1000tr from seasonic looks the difference


good word about spread spectrum

spread spectrum is a hot topic of debate if it actually "works" it's just spreading out the energy some more. it doesn't reduce the overall power leakage
it helps meet the legal requirements, but the effect on actual interference is debated

sorry yonaxsangi the whole problem come from PSU

ax1600i Huge emi

https://streamable.com/hijvkt

hx1200i Extreme low emi

https://streamable.com/skoc1u
hello brother i had corsair hx1200, evga supernova and all this power supplies but this didnt helped me always was good in the first time but after some hours its come back. but now i have seasonic psu with 1000watt and what interesting in seasonic power supplies its the DC to DC power convertor. Most of the power supplies is AC to DC. so after puting this psu i dont the speedhack gaming effect but the prefires and bad hitreg was still there

Ilim
Posts: 4
Joined: 21 Oct 2020, 16:31

Re: Electricity input lag fix !

Post by Ilim » 19 Apr 2021, 01:41

Hello, I also have MOBO msi z390a-pro. I cannot unlock my BIOS on my own. Could you post a link with a modified BIOS to the forum. I will be very grateful to you.

Post Reply