Page 1 of 1

Xl2720Z V5 - Display Port . "No signal" when waking up if monitor was turned off

Posted: 13 Jan 2021, 06:51
by Buchette
Hi, to begin with i always used the monitor on dual DVI. I just ordered a display port cable to check if everything works as indented on this kind of cable because next gen GPUs are mostly lacking DVI.

My Monitor has V5 Firmware i flashed myself years ago with the Mstar adapter.

I bought what is supposed to be a good VESA certified cable and it looks very nice indeed : ... 87&sr=8-18

At 1st i had some issues : no display at all. Used DDU to clean the drivers, reinstalled them and finally succeeded.

Since i never had any issue at boot, or when i use it.

But my problem is this one: everytime i turn off the monitor AND the display go on sleep (windows settings), i always have the "no signal" message when i push the monitor power button. The only way to get a display is to unplug and replug the DP cable.

If i move my mouse to wake before i power on the monitor : "no signal" => needs to unplug/replug the DP cable
If i power on the monitor then wake moving my mouse, typing a key whatever : sometimes it works

So it's like the monitor loses the connection with the GPU.

My GPU is a GTX1080. I flashed it with the Nvidia displayport firmware ( ... pdate-x64/) which is meant to fix issues with DP 1.3/1.4 . Anyways XL2720Z is DP 1.2

I tried pretty everything i could think about :
-disabled every sleep mode on the mainboard. Still S0/S1 is active only.
-disabled hdmi autoswitch on the benq monitormenu
-tried to change various settings on the service menu such as "auto power"
-disabled hdmi autoswitch on monitor settings

=> Now i'm clueless.

If it's an issue with my GTX1080, it's not really a problem because i can go back on DVI until i get a new card with only DP to get 60+Hz, but if it's a monitor issue, not matter the GPU i hook on, i really need to fix it.

Any clue ? Thanks :)

Re: Xl2720Z V5 - Display Port . "No signal" when waking up if monitor was turned off

Posted: 13 Jan 2021, 08:02
by Buchette
Edit: switched to an AMD RX580 to give a try and i have not reproduced the issue so far.