Page 1 of 1

HOWTO: Fix "TestUFO stuck at 60Hz" FAQ

PostPosted: 31 Aug 2017, 15:27
by Chief Blur Buster
Fixing TestUFO "Stuck at 60Hz" problems

Aka: "TestUFO not working at 144Hz", "TestUFO not working at 120Hz"

TestUFO demands high performance for perfect stutter-free operation. Most web browsers often are stubborn at running at the correct refresh rate, and often stays stuck at 60fps even if you're at a high refresh rate. Unfortunately, web browsers are a very finicky beast, and is often impossible to detect the correct refresh rate in certain web browsers; ending up saying "60Hz" when it is actually 120Hz or 144Hz. That can often happen due to many causes. Several tips are listed at but this thread documents more tips.

There are frequent comments about TestUFO being "stuck at 60Hz".
Here are the common solutions:

Doublecheck Control Panel
Verify your monitor is actually running Windows above 60Hz first. You probably already did this, but please doublecheck first before the next step. ;)

Temporarily Turn off Multiple Monitor Mode: Don't Mix Two Refresh Rates
Multiple monitors running at different refresh rates, often interfere with correct TestUFO refresh rate. Make all your monitors all equal to the highest refresh rate, or instead disable multi-monitor.

Laptops Connected To Gaming Monitors
Such as a 144Hz monitor connected to a 60Hz laptop. Close the laptop lid and make the 144 Hz monitor the primary and only monitor.

Use Aero Mode. Don't Use "Windows Basic Mode"
If you're using Windows 7, don't use "Windows Basic Mode". If you're using Windows Vista, don't turn off "Aero".

Try Using Different Browser
TestUFO is currently optimized to work very well with Google Chrome. IE/Edge only runs up to 105Hz, while Chrome runs reliably at 240Hz (if no other applications are running). FireFox also works well (with the stutter fix below).

Fixing Chrome Stutters
Try quitting all applications and windows. Pause your cloud sync (Dropbox) and other background apps. Temporarily reboot in Safe Mode (but enable the graphics driver).

Fixing FireFox Stutters
Occasionally, there are situations where a specific computers only runs 60Hz Chrome but has correct Hz in FireFox. However, FireFox often stutters quite a lot at high refresh rates until you temporarily set minimum CPU to 100%. When adjusted this way, it successfully runs at all current refresh rates.

Check chrome://gpu
Make sure everything is hardware accelerated. Sometimes Chrome will go into software rendering mode that has a 60fps cap.

Check chrome://flags
Sometimes GPU acceleration is disabled. Try enabling GPU acceleration.

Test Balanced Mode or Performance Mode
Power-saving mode may force a browser into a 60Hz mode even with laptops connected to an external display.

Upgrade Graphics Drivers
Sometimes certain web browsers blacklists certain graphics drivers from properly working at full frame rate. A graphics driver upgrade may fix this.

Retest Two Browsers Again
Try both FireFox and Chrome again after you've done all the above (settings tweaks, driver upgrades, etc). Occasionally, one of two web browsers suddenly runs at above 60fps -- so it's best to cover all bases.

Test using native Windows. Don't use a Virtual Machine
Virtual Machines are often stuck at 60Hz. If you are using Parallels or VMWare, please retest natively rather than inside a VM or emulator. Windows works best with TestUFO.

Success? New tips?
Please post what tip fixed your "Stuck at 60Hz" problem. Additional tips will help many users!

If you have failed to figure out what to do, please do the following
1. Copy and paste the browser useragent found at bottom of
2. Screenshot your Control Panel -> Display refresh rate (or Custom Resolution Utility screen)
3. Screenshot your animation time graph from
4. Mention which web browsers you have already tested (retest all browsers after trying all fixes)

Re: HOWTO: Fix "TestUFO stuck at 60Hz" FAQ

PostPosted: 02 Jan 2018, 12:21
by Chief Blur Buster
Last Resort Steps for Stubborn Chrome Browsers

Chrome falling back to 60Hz is often caused by Chrome's somewhat-flawed GPU-driver-blacklisting behaviour. Sometimes it has good intentions, but for a minor graphics driver bug, it sometimes disables excessively huge numbers of hardware-accelerated features just to get around a teensy GPU driver bug...

Go to chrome://flags and then:
-- "Override software rendering list" = Enable
-- "Accelerated 2D Canvas" = Enable

If that doesn't work, try also:
-- "GPU rasterization" = Enable