Blur Busters Forums

Who you gonna call? The Blur Busters! For Everything Better Than 60Hz™ Skip to content

Chrome fullscreen mode suddenly tearing like crazy

Everything about displays and monitors. 120Hz, 144Hz, 240Hz, 4K, 1440p, input lag, display shopping, monitor purchase decisions, compare, versus, debate, and more. Questions? Just ask!

Chrome fullscreen mode suddenly tearing like crazy

Postby kooz » 10 Oct 2018, 08:14

I noticed this yesterday while watching YouTube in full screen. At first, I thought there was something wrong with the creator's capture/encoding process, but after seeing another video with the same artifacts, I knew something was wrong.

Long story short, after a bit of troubleshooting I came to the realization that something has been recently broken with full screen mode in Chrome, or, at least for me anyway. There were no driver or other obvious software updates to prompt this issue. I know that Chrome updates itself completely autonomously, so I'm fairly certain it's just a problem or "experimental feature" with a recent build.

GTX 1080/Win10. Nvidia drivers were at 380-something and I just updated to 416.16. No change. Firefox does not exhibit this issue.

Recorded the behavior using the slo-mo option on my iPhone6:!VQc0DApK!APP-739BsRob ... lHNn15vCJ4

Notice how the problem doesn't start until the "Press F11 to exit full screen" overlay fully fades away. Weird, eh?

It will probably go away in a few days, but I found it interesting (and annoying). Anyone else having this problem?
Posts: 9
Joined: 01 Feb 2017, 15:48

Re: Chrome fullscreen mode suddenly tearing like crazy

Postby Chief Blur Buster » 11 Oct 2018, 02:49

Chrome seems to be running in a new full screen mode for reduced browser lag -- with some interesting side effects. On my system, Chrome switches on the VRR mode in fullscreen mode.

In your NVIDIA Control Panel, is full screen exclusive mode using VSYNC OFF? You can also try forcing a full screen sync mode via profiles (force VSYNC ON mode to Chrome). Chrome normally should be a VSYNC ON only application. Chrome should be configuring this automatically so there might be a browser bug too -- but you may be able to force VSYNC ON back onto the browser.
Head of Blur Busters - | | Follow @BlurBusters on Twitter

       To support Blur Busters:
       • Official List of Best Gaming Monitors
       • List of G-SYNC Monitors
       • List of FreeSync Monitors
       • List of Ultrawide Monitors
User avatar
Chief Blur Buster
Site Admin
Posts: 5733
Joined: 05 Dec 2013, 15:44

Re: Chrome fullscreen mode suddenly tearing like crazy

Postby RealNC » 11 Oct 2018, 11:24

Yes. Noticed it too now. I usually have vsync set to ON in the nvidia panel, but switching it to off makes Chrome tear in fullscreen mode.

So if you have vsync off in the nvidia panel, you need to set it to "application preference" in Chrome's nvidia profile.
TwitterSteamGitHubStack Overflow
The views and opinions expressed in my posts are my own and do not necessarily reflect the official policy or position of Blur Busters.
User avatar
Posts: 2466
Joined: 24 Dec 2013, 18:32

Re: Chrome fullscreen mode suddenly tearing like crazy

Postby kooz » 15 Oct 2018, 08:31

As expected, this went away on its own.

You guys are awesome and I feel bad for not checking back earlier. Interestingly enough, I had actually already set vsync to "on" globally in my nVidia control panel. I hadn't made any changes there since purchasing my GTX 1080 just over a year ago. I certainly did not ever apply full screen exclusive mode settings, and TBH I'm not sure how I could specify that in the first place. I did try using Chrome flags to correct this as well via overlay/canvas/etc rendering overrides.

I have several other personal machines (as well my office workstation) which did not exhibit this issue, though none of them have an nVidia GPU.

This is all very strange indeed, and thank you to those who viewed/responded. I'm glad to see at least one person was able to reproduce this issue, even if it was under different circumstances.

RealNC, out of curiosity, if you have vsync off in nVidia control panel, are you still getting the same effect? It doesn't happen for me anymore, even if I specify "off" globally.

EDIT: Scratch that last question - I am able to reproduce the issue after specifying vsync off in my nVidia control panel and completely shutting down/restarting Chrome. For the record, I never did try restarting to fix this earlier. Maybe it was some sort of driver bug after all.
Posts: 9
Joined: 01 Feb 2017, 15:48

Return to General — Displays, Graphics & More

Who is online

Users browsing this forum: Google [Bot], ogchampion and 9 guests