Faulty g-sync?

Talk about NVIDIA G-SYNC, a variable refresh rate (VRR) technology. G-SYNC eliminates stutters, tearing, and reduces input lag. List of G-SYNC Monitors.
yoyoa
Posts: 6
Joined: 17 Dec 2017, 07:12

Faulty g-sync?

Post by yoyoa » 17 Dec 2017, 09:53

Hello.

I bought a new monitor for me, an used Acer XB270HU (144hz, 27', g-sync and IPS) and instantly felt that something was off... I had 2 different g-sync monitors Dell S2716DH and Acer Predator XB241H so I was used to play with g-sync.

Basically stutters happens when your fps fall down a little bit (even 144fps to 130fps), and sometimes there's some kind of micro frame skip.

With g-sync off the stutter still happens (well, there's no g-sync) and "micro frame skip" disappears.

Tried almost every combination possible on Nvidia control panel with/and game settings, did clean install of various old drivers and even tried it on a fresh install of Windows 7.

I ordered a VESA certified DP cable which I used on my older monitors (they didn't came for some reason) but I don't think it's the cables fault...

Like I said, had two different g-sync monitors in the past using the same system and never experienced something like that...

Is it even possible to have a fault g-sync module or something like that? What do you guys think?

Thanks :(

User avatar
lexlazootin
Posts: 1251
Joined: 16 Dec 2014, 02:57

Re: Faulty g-sync?

Post by lexlazootin » 17 Dec 2017, 11:01

Check if you get frame skipping, If you are you could have a faulty chip.

https://www.testufo.com/frameskipping

Make sure you disable everything in the startup section in talk manager on windows10 and reboot as even Anti-viruses can cause latency spikes

Run a very stable game (HL/CS 1.6/Source anything easy to run) and see if you get spikes when capping at 130fps

yoyoa
Posts: 6
Joined: 17 Dec 2017, 07:12

Re: Faulty g-sync?

Post by yoyoa » 18 Dec 2017, 03:46

lexlazootin wrote:Check if you get frame skipping, If you are you could have a faulty chip.

https://www.testufo.com/frameskipping

Make sure you disable everything in the startup section in talk manager on windows10 and reboot as even Anti-viruses can cause latency spikes

Run a very stable game (HL/CS 1.6/Source anything easy to run) and see if you get spikes when capping at 130fps
Thanks for the reply.

Took 4 photos using different settings on my smartphone: https://imgur.com/a/VwX5g
I think looks... fine...?

The games I tried: Dota 2 (I play this a lot), CSGO, Team Fortress 2, Rise of Tomb Raider, Crysis, Half Life 2, CS 1.6.

I think there's no "frame skipping" while playing older games like CS and HL2 with a fixed frame rate.

Newer games that I can't maintain a fixed frame rate, any variation in fps causes micro stutters.

User avatar
Chief Blur Buster
Site Admin
Posts: 8361
Joined: 05 Dec 2013, 15:44
Location: Toronto / Hamilton, Ontario, Canada
Contact:

Re: Faulty g-sync?

Post by Chief Blur Buster » 19 Dec 2017, 17:03

Looks fine to me. It's not frameskipping as far as I can see.

One possibility is your G-SYNC monitor is not in G-SYNC mode.

Does it say "G-SYNC Mode" or "Normal Mode" in the monitor menus?

Uninstall-reinstall driver, and trying a different port on your graphics card can also help.
Head of Blur Busters - BlurBusters.com | TestUFO.com | Follow @BlurBusters on Twitter

       To support Blur Busters:
       • Official List of Best Gaming Monitors
       • List of G-SYNC Monitors
       • List of FreeSync Monitors
       • List of Ultrawide Monitors

User avatar
RealNC
Site Admin
Posts: 3078
Joined: 24 Dec 2013, 18:32
Contact:

Re: Faulty g-sync?

Post by RealNC » 19 Dec 2017, 17:27

To make sure g-sync is working, enable the g-sync indicator in the nvidia control panel. It's a setting somewhere in the menus. (Meaning the menubar at the top of the window.)

When you start a game, you should get a big g-sync logo in-game. If not, g-sync is not working correctly.
SteamGitHubStack OverflowTwitter
The views and opinions expressed in my posts are my own and do not necessarily reflect the official policy or position of Blur Busters.

yoyoa
Posts: 6
Joined: 17 Dec 2017, 07:12

Re: Faulty g-sync?

Post by yoyoa » 20 Dec 2017, 01:20

RealNC wrote:To make sure g-sync is working, enable the g-sync indicator in the nvidia control panel. It's a setting somewhere in the menus. (Meaning the menubar at the top of the window.)

When you start a game, you should get a big g-sync logo in-game. If not, g-sync is not working correctly.
Chief Blur Buster wrote:Looks fine to me. It's not frameskipping as far as I can see.

One possibility is your G-SYNC monitor is not in G-SYNC mode.

Does it say "G-SYNC Mode" or "Normal Mode" in the monitor menus?

Uninstall-reinstall driver, and trying a different port on your graphics card can also help.
Thanks for the replies.

I modified the display settings on Nvidia control panel to show the g-sync logo and it shows...

Monitor OSD also says g-sync, it changes to "normal" when I deactivate g-sync. Already uninstalled and reinstalled different drivers multiple times using DDU. Tried using another DP ports.

Testing with TF2 right now, it's clear something is off using 2 monitor/machines.

In the XB270HU with my man rig, I spam a lot of bots to make my frame rate go down and fluctuate to about 80 fps, move around the camera and is unplayable with a lot of stuttering.

Using another rig (an old "gaming laptop") plugged onto a 60hz monitor, same place with constant 60fps moving around the camera and no stuttering...

Setting the XB270HU to 60hz in my main rig and having a constant 60fps does not stutter.

Not sure what do do, if isn't the monitor could be my graphics card? It's a gtx1070 and was perfectly fine 2-3 months ago using with a XB241H and 1 year ago with a S2716DG. :|


Another thing I noticed, not sure if it's intended or not. G-sync only works with 144hz. If I set 120hz, 100hz, 80hz or 60hz and open a game, the monitor changes the refresh rate to 144hz, it goes back to whatever hz if I alt tab or close the game.

Only way to game with 120hz, 100hz, 80hz or 60hz is disabling g-sync.

User avatar
RealNC
Site Admin
Posts: 3078
Joined: 24 Dec 2013, 18:32
Contact:

Re: Faulty g-sync?

Post by RealNC » 20 Dec 2017, 02:00

The refresh rate is forced in the nvidia panel, in the 3D settings section. It's the "preferred refresh rate" setting, which is set to "maximum" when enabling g-sync. Setting it to "application preference" will not force 144Hz anymore. However, with g-sync it's highly recommended to use the max refresh rate.
SteamGitHubStack OverflowTwitter
The views and opinions expressed in my posts are my own and do not necessarily reflect the official policy or position of Blur Busters.

User avatar
Chief Blur Buster
Site Admin
Posts: 8361
Joined: 05 Dec 2013, 15:44
Location: Toronto / Hamilton, Ontario, Canada
Contact:

Re: Faulty g-sync?

Post by Chief Blur Buster » 20 Dec 2017, 21:09

At the moment, I still think it is a configuration issue forcing G-SYNC to do something you don't want it to. Not a hardware issue (though GSYNC hardware problems have happened before -- defective G-SYNC and FreeSync monitors have occured before, but this is rarer than a configuration problem)

-- Try uninstalling all NVInspector tweaks. Temporarily remove all frame capping software (for now)

-- Test your monitor with a different computer with an NVIDIA product. Does the problem follow the monitor? Or stay with the GPU?

-- Reinstall a new copy of windows. (If you don't want to touch your existing Windows, temporarily install an old HDD, or make this your opportunity to upgrade your disk)
Head of Blur Busters - BlurBusters.com | TestUFO.com | Follow @BlurBusters on Twitter

       To support Blur Busters:
       • Official List of Best Gaming Monitors
       • List of G-SYNC Monitors
       • List of FreeSync Monitors
       • List of Ultrawide Monitors

yoyoa
Posts: 6
Joined: 17 Dec 2017, 07:12

Re: Faulty g-sync?

Post by yoyoa » 21 Dec 2017, 03:59

Chief Blur Buster wrote:At the moment, I still think it is a configuration issue forcing G-SYNC to do something you don't want it to. Not a hardware issue (though GSYNC hardware problems have happened before -- defective G-SYNC and FreeSync monitors have occured before, but this is rarer than a configuration problem)

-- Try uninstalling all NVInspector tweaks. Temporarily remove all frame capping software (for now)

-- Test your monitor with a different computer with an NVIDIA product. Does the problem follow the monitor? Or stay with the GPU?

-- Reinstall a new copy of windows. (If you don't want to touch your existing Windows, temporarily install an old HDD, or make this your opportunity to upgrade your disk)

I never installed NVInspector and I'm not using any frame capping software (using ingame frame caping in "light" games where I can achieve 144fps).

I did a fresh install of windows 7 on my spare HDD, tried multiple drivers and etc...

Still have an old GTX660 which I didn't even bother to resell because it started to give random crashes while gaming for long periods, tested with it and the behavior is the same.

Thanks for your attention.

yoyoa
Posts: 6
Joined: 17 Dec 2017, 07:12

Re: Faulty g-sync?

Post by yoyoa » 28 Dec 2017, 02:39

No hope? :(

Post Reply