Blur Busters Forums

Who you gonna call? The Blur Busters! For Everything Better Than 60Hz™ Skip to content

Overclocked Notebook Panel - GSync Tearing

Talk about NVIDIA G-SYNC, a variable refresh rate (VRR) technology. G-SYNC eliminates stutters, tearing, and reduces input lag. List of G-SYNC Monitors.

Overclocked Notebook Panel - GSync Tearing

Postby TEAML6Kiba » 07 Jan 2019, 08:35

Hey guys/girls,

First of all: Happy new year! And please excuse the mistakes. German here :P

I didn't find any clear answer about this topic on the first 3 pages of Google. Neither here.
So please forgive me if this has already been discussed.

I just got this Laptop with GSync Support:

Medion Erazer X7857
i7 7700HQ
GTX 1070
GSync capable IPS Display with 75Hz

I know, this thing runs hot as hell (-110mV undervolt solves the heat issue for the most part :P). But that's not my issue.
I managed to overclock the internal display to 100Hz without any frameskipping. The response time is great and gameplay feels completely smooth for the most part.

Just GSync doesn't want to work properly. In Destiny 2 for example I get variable Framerates of 75 to 120. I know that as soon as the FPS are exceeding my displays refresh rate, VSYNC kicks in.
I disabled that in the NCP and I'm completely fine with tearing at 100 FPS+. But even if my FPS hover around 95 FPS I get screen tearing. Even though GSync is working (at least the indicator overlay says so). Other Games I tested don't work either.

So my question is:

Why doesn't GSync work with my custom refresh rate?

Things i've tried so far:

- Limit FPS to 3 below Max Refresh Rate = Tearing
- Disable Overclock = Tearing at 75FPS+, everything fine below that value
- Different Settings in NCP (Force Fullscreen Scaling and disable any Application based values etc.) = Tearing OR 75Hz lock + Input lag ignoring the overclock
- Set GSync to Fullscreen + Windowed and tried all the different options (Game on Fullscreen, Game Borderless, etc.)

I'm completely out of ideas right now. It seems like GSync only works at the native refresh rate of 75Hz or below for whatever reasion.
I don't like the idea of having to dish out another couple of $$$ to get a decent GSync Monitor :/.

Do you have any idas on this one?

Thanks in advance

Kiba
TEAML6Kiba
 
Posts: 5
Joined: 07 Jan 2019, 08:19

Re: Overclocked Notebook Panel - GSync Tearing

Postby RealNC » 08 Jan 2019, 08:02

You need to enable vsync in the nvcp, disable vsync in-game, and apply an FPS to 3FPS below the current refresh rate. At 100Hz, cap to 97FPS. At 75Hz, cap to 72FPS.

For the full details on this, you can read the 14-part article:

https://www.blurbusters.com/gsync/gsync101

The sections about vsync and frame capping in particular.
TwitterSteamGitHubStack Overflow

The views and opinions expressed in my posts are my own and do not necessarily reflect the official policy or position of Blur Busters.
User avatar
RealNC
 
Posts: 2296
Joined: 24 Dec 2013, 18:32

Re: Overclocked Notebook Panel - GSync Tearing

Postby TEAML6Kiba » 08 Jan 2019, 08:15

That's exactly what I tried at first.
As soon as I enable VSync or Fast-Sync in the NVCP my FPS are automatically capped at 75, ignoring the initial Refresh Rate Overclock and adding the typical input lag.
TEAML6Kiba
 
Posts: 5
Joined: 07 Jan 2019, 08:19

Re: Overclocked Notebook Panel - GSync Tearing

Postby RealNC » 08 Jan 2019, 08:32

That means the game is switching to 75Hz then. Your custom mode is not getting used by the game.

Have you tried setting "preferred refresh rate" to "highest available" in the nvcp's "3d settings"? If that doesn't work, have you tried moving your custom mode to the top of the list in CRU? (Are you actually using CRU to add the custom mode?)

Also, I'm not sure if the integrated graphics chip is interfering. Is it possible to disable it?
TwitterSteamGitHubStack Overflow

The views and opinions expressed in my posts are my own and do not necessarily reflect the official policy or position of Blur Busters.
User avatar
RealNC
 
Posts: 2296
Joined: 24 Dec 2013, 18:32

Re: Overclocked Notebook Panel - GSync Tearing

Postby jorimt » 08 Jan 2019, 08:37

What RealNC said...

But if that doesn't work, then from the info you've provided, it sounds like while your physical refresh rate may be successfully overclocked, it doesn't necessarily mean G-SYNC recognizes it, and thus stops kicking in when the display is set to any refresh rate above 75Hz.

As far as I'm aware, G-SYNC laptops don't have an actual module, but run entirely via software/driver, so, for all we know, there could be a hard max range or Hz limit for G-SYNC in place, tuned specifically for that internal display.

May or may not be the case though; I've never tested laptop G-SYNC, so I can't say anything for certain.
Author: "G-SYNC 101" Series

Display: Acer Predator XB271HU OS: Windows 10 MB: ASUS ROG Maximus X Hero CPU: i7-8700k GPU: EVGA GTX 1080 Ti FTW3 RAM: 16GB G.SKILL TridentZ DDR4 @3200MHz
User avatar
jorimt
 
Posts: 515
Joined: 04 Nov 2016, 10:44

Re: Overclocked Notebook Panel - GSync Tearing

Postby TEAML6Kiba » 08 Jan 2019, 10:16

Hi!

Thanks for the quick replies :).

I try to answer everything as best as I can.

Have you tried setting "preferred refresh rate" to "highest available" in the nvcp's "3d settings"?


Sadly, I don't have that option inside of my 3d Settings. For this reason I downloaded NVIDIA Inspector, in which it already stood on "highest available". I guess this feature simply isn't available when using the internal notebook display?

have you tried moving your custom mode to the top of the list in CRU? (Are you actually using CRU to add the custom mode?)


Usally I'm using the NVCP custom resolution settings. I tried using CRU once but upon restarting the video card driver my screen crashed and had to use a recovery point. I guess I did something wrong with the EDID override. I will look into this tonight!

I'm not sure if the integrated graphics chip is interfering. Is it possible to disable it?


The Intel Chip is definitely deactivated via Software. You can switch between a "Separate" and "MSHybrid" Mode inside of the Notebooks Control Center (Clevo based). I always leave it at "Separate" and the Intel GPU is missing from the device Manager.

One additional Note:

Everything worked until I updated to Win10 1809. I'll try a clean install of the display driver and maybe I can still roll back if that doesn't do the trick.

I will report back as soon as I am released from my slavery :P
TEAML6Kiba
 
Posts: 5
Joined: 07 Jan 2019, 08:19

Re: Overclocked Notebook Panel - GSync Tearing

Postby TEAML6Kiba » 08 Jan 2019, 18:02

EDIT:

After I was able to wreck my System somehow with some sort of misconfiguration (BAD_SYSTEM_CONFIG_INFO Bluescreen) and recovering the registry I managed to get the custom Resolution working. The Drop-Down Selection with preferred refresh rate also shows up now. But nothing helps. Clean install of the NVIDIA driver didn't work either. Guess I'll have to settle with the idea of buying a new monitor for GSYNC past 75Hz. I hope that the new drivers NVIDIA keep their promise of enabling GSYNC with FreeSync monitors.
TEAML6Kiba
 
Posts: 5
Joined: 07 Jan 2019, 08:19


Return to G-SYNC

Who is online

Users browsing this forum: No registered users and 10 guests