Gsync worked, now doesn't! Help!!!

Talk about NVIDIA G-SYNC, a variable refresh rate (VRR) technology. G-SYNC eliminates stutters, tearing, and reduces input lag. List of G-SYNC Monitors.
Post Reply
m_staf
Posts: 3
Joined: 28 Sep 2020, 22:27

Gsync worked, now doesn't! Help!!!

Post by m_staf » 01 Oct 2020, 10:32

Hello,

I have been having much trouble with my G-sync intermittently working for seemingly no rhyme or reason for months. I have followed all of the recommended steps for setting up Gysnc and have a Gsync certified monitor (Asus TUF VG27A). Gsync WILL work for a few of the games on my computer such as Red Dead Redemption 2 and Rise of the Tomb Raider. I can tell that it is working because of the Gsync enabled badge appearing in the game and a noticeable improvement in tearing. The framerate on the monitor will also sync with the framerate of the game. Gsync will not however work in games like Battlefield V or World of Warcraft classic (it previously did when I first built my computer). I figured this may be due to improper in game settings on my end at first. However, when using the Nvidia pendulum demo, I have never once been able to select the Gsync box in the demo. There are no signs of Gsync working at all in the demo and it is accompanied by terrible frame rate tearing.
I have done a clean reinstall of the drivers, tried multiple monitors, display port cables, HDMI cables, etc, default Nvidia control pannel settings. I have also tried using only a single monitor. Nothing has seemed to work at all! It is incredibly frustrating as I have combed forums and boards for months looking for a solution. It is also upsetting spending the extra money for a certified Gsync monitor and still having the issues. I usually have a dual monitor setup. One monitor is a freesync Acer XF270HUA and the other is the Asus previously mentioned. I have tried testing one monitor at a time with the same issues so I do not believe it to be the fault of having dual monitors.

All settings on nvidia control panel are default besides the following

Set up G-SYNC > Enable G-SYNC, G-SYNC Compatible > Enable for full screen mode.
Manage 3D settings > Max Frame Rate 162 FPS
Manage 3D settings > Vertical sync >ON

Do you have any ideas of what could be causing the issue or inconsistency?

Thank you for your time and help!

User avatar
jorimt
Posts: 1289
Joined: 04 Nov 2016, 10:44
Location: USA

Re: Gsync worked, now doesn't! Help!!!

Post by jorimt » 01 Oct 2020, 13:10

m_staf wrote:
01 Oct 2020, 10:32
We discussed this in the G-SYNC 101 comments section a little over a month ago. Unfortunate to hear you're still having the issue.

To start, the last couple of drivers have cause some issues with G-SYNC Compatible FreeSync monitors, so make sure you have this version of the driver installed (I suggest using DDU to be safe) before troubleshooting further:
https://nvidia.custhelp.com/app/answers ... ion-452.22

That said, I'm aware your issue predates said drivers.

I can only go by what you say, and if I do, unless there is some serious user error you're failing to mention (last ditch; does your monitor menu have a FreeSync toggle, and if so, is it enabled?), there's little else you can try.

Thus, with your provided info, the only logical conclusion left considering is that your monitor is faulty, and something involving FreeSync implementation failed shortly after you received it.

Have you considered an RMA?
(jorimt: /jor-uhm-tee/)
Author: Blur Busters "G-SYNC 101" Series

Display: Acer Predator XB271HU OS: Windows 10 Pro MB: ASUS ROG Maximus X Hero CPU: i7-8700k GPU: EVGA GTX 1080 Ti FTW3 RAM: 32GB G.SKILL TridentZ @3200MHz

m_staf
Posts: 3
Joined: 28 Sep 2020, 22:27

Re: Gsync worked, now doesn't! Help!!!

Post by m_staf » 01 Oct 2020, 15:35

Thank you for taking the time to help me again Jorimt!

I tried installing the driver you linked to no avail.

I really do not think this is a hardware issue as it is occurring in both my gsync certified monitor as well as my secondary freesync monitor. After some tinkering I was able to get Gsync to work with battlefield 5 ONLY in windowed mode. It will not work in fullscreen or windows borderless. So gsync IS working in RDR2, Rise of the Tomb Raider, and BF5 (in windowed mode).

m_staf
Posts: 3
Joined: 28 Sep 2020, 22:27

Re: Gsync worked, now doesn't! Help!!!

Post by m_staf » 01 Oct 2020, 15:46

Wow, So huge breakthrough, all though I dont know what is causing it or how to fix it, but after some tinkering around, I have Gsync working in WINDOWED mode in Battlefield 5 and World of Warcraft. So there is something that my computer does not like about fullscreen games and Gsync. As stated before, Gsync does work in a very select few games I own in fullscreen mode. Any idea how to get it to work on the other ones in fullscreen?

User avatar
jorimt
Posts: 1289
Joined: 04 Nov 2016, 10:44
Location: USA

Re: Gsync worked, now doesn't! Help!!!

Post by jorimt » 01 Oct 2020, 16:12

m_staf wrote:
01 Oct 2020, 15:46
Wow, So huge breakthrough, all though I dont know what is causing it or how to fix it, but after some tinkering around, I have Gsync working in WINDOWED mode in Battlefield 5 and World of Warcraft. So there is something that my computer does not like about fullscreen games and Gsync. As stated before, Gsync does work in a very select few games I own in fullscreen mode. Any idea how to get it to work on the other ones in fullscreen?
What you're describing is highly unusual behavior. With "Enable for full screen mode," G-SYNC should only function when the game is set to exclusive fullscreen mode. What do you have it set to in the NVCP now?

Just to make sure it's applying to everything, select "Enable for windowed and full screen mode," if you haven't already.

Also, have you ever messed with "enabled fullscreen optimizations" per game exe? Because that could be contributing to this as well.
(jorimt: /jor-uhm-tee/)
Author: Blur Busters "G-SYNC 101" Series

Display: Acer Predator XB271HU OS: Windows 10 Pro MB: ASUS ROG Maximus X Hero CPU: i7-8700k GPU: EVGA GTX 1080 Ti FTW3 RAM: 32GB G.SKILL TridentZ @3200MHz

Post Reply