Blur Busters Forums

Who you gonna call? The Blur Busters! For Everything Better Than 60Hz™ Skip to content

Yamakasi Catleap overclock on linux (RX580 amdgpu)

Talk about overclocking displays at a higher refresh rate. This includes homebrew, 165Hz, QNIX, Catleap, Overlord Tempest, SEIKI displays, certain HDTVs, and other overclockable displays.

Yamakasi Catleap overclock on linux (RX580 amdgpu)

Postby mahalel » 17 Jan 2019, 14:46

Hello everyone, I have searched your forums (which are a great resource by the way) but I can't see anything about this.
It's a bit of a longshot but I am running Ubuntu 18.10 on my main machine and play games on steam, really only Rocket League.

I have a Yamakasi Catleap monitor which historically I can push to about 2560x1440 @ 110hz without any artifacts.

Up until recently I had a R9 280x gpu and set a custom refresh rate of 96hz via xrandr, everything worked well and smooth and I was happy, but the frames weren't that good at 2560x1440.

I have just upgraded to a 580X 8gb AMD card and I thought it would be as easy as using the same xrandr command, but whenever I try to apply that refresh rate to DVI-D-0 I get an error of "Configure crtc 0 failed". I just can't seem to push past 60hz on this card.

I've tried various things, like setting custom EDID in xorg.conf and using a hacked EDID which is supposed to advertise 96hz as a valid refresh rate but it doesn't seem to apply at all.

I'm a bit down in the rabbit hole at the moment and 60hz just feels like dogshit to me, so I am desperately hoping there's someone else on this forum with a similar setup that can give me some advice :)

The alternative is installing Windows but I get shivers when I entertain that thought so I'd like to get this working if possible.
mahalel
 
Posts: 2
Joined: 17 Jan 2019, 14:37

Re: Yamakasi Catleap overclock on linux (RX580 amdgpu)

Postby RealNC » 17 Jan 2019, 16:04

Does the video card have another DVI port? Is yes, try another one. Some video cards have two DVI ports, only one of which is actually DL-DVI.
TwitterSteamGitHubStack Overflow

The views and opinions expressed in my posts are my own and do not necessarily reflect the official policy or position of Blur Busters.
User avatar
RealNC
 
Posts: 2442
Joined: 24 Dec 2013, 18:32

Re: Yamakasi Catleap overclock on linux (RX580 amdgpu)

Postby Chief Blur Buster » 17 Jan 2019, 20:52

Yes, try a different DVI port.

Also, I've seen dual-link DVI cables fail and become single-link DVI cables. Switch cables if needed.

I've also seen failed DVI ports too.

Could also be a driver issue with 580 on Linux not enabling dual-link DVI.

Unorthodox workarounds could include DisplayPort-to-DualLink DVI adaptors, or HDMI2-to-DualLink DVI. They're not always very reliable, but can bypass a GPU-side unexpected refusal of dual-link DVI for any hardware/software reason. Get a high-rated adaptor that has success reports of 1440p 120Hz.
Head of Blur Busters - BlurBusters.com | TestUFO.com | Follow @BlurBusters on Twitter

       To support Blur Busters:
       • Official List of Best Gaming Monitors
       • List of G-SYNC Monitors
       • List of FreeSync Monitors
       • List of Ultrawide Monitors
User avatar
Chief Blur Buster
Site Admin
 
Posts: 5630
Joined: 05 Dec 2013, 15:44

Re: Yamakasi Catleap overclock on linux (RX580 amdgpu)

Postby mahalel » 23 Jan 2019, 18:25

Hey, thanks for the replies.

Only one DVI port on the GPU unfortunately.
I have borrowed a different monitor which has an EDID advertising 2560x1440 @ 120hz
xrandr still only detects 2560x1440 @ 60hz

I think I will temporarily boot windows to see if this is purely a driver issue. I suspect the amdgpu driver is locking the clocks at a certain value.

Will report once I've made more progress, thanks for the advice so far.
mahalel
 
Posts: 2
Joined: 17 Jan 2019, 14:37


Return to Display Overclocking

Who is online

Users browsing this forum: No registered users and 1 guest